MT4指标ATRStops 移植到金字塔交易系统

By tim2025 at 2020-09-12 • 0人收藏 • 80人看过

MT4指标ATRStops 移植到金字塔交易系统

img_20191003.png


img_20191003(1).png

VARIABLE: CHANNELPERIOD=9,RISK=0.30,SIGNAL=1,LINE=1,NBARS=1000;
VARIABLE:UPTRENDBUFFER=-2,DOWNTRENDBUFFER=-2;

IF BARPOS<CHANNELPERIOD THEN EXIT;

SMAX:=HHV(H,CHANNELPERIOD);
SMIN:=LLV(L,CHANNELPERIOD);
BSMAX:=SMAX-(SMAX-SMIN)*RISK;
BSMIN:=SMIN+(SMAX-SMIN)*RISK;
CSMAX:=REF(BSMAX,1);
CSMIN:=REF(BSMIN,1);

IF (C>CSMAX) THEN  TREND0:=1; 
IF (C<CSMIN) THEN  TREND0:=-1;
IF (TREND0>0 && BSMIN<CSMIN)THEN  BSMIN:=CSMIN;
IF (TREND0<0 && BSMAX>CSMAX)THEN  BSMAX:=CSMAX;
LUTB:=REF(UPTRENDBUFFER,1);
LDTB:=REF(DOWNTRENDBUFFER,1);
IF (TREND0>0) THEN BEGIN
	IF (SIGNAL>0 && LUTB=-1.0) THEN BEGIN
		UPTRENDSIGNAL:=BSMIN;
	     IF (LINE>0) THEN  BEGIN
	     UPTRENDLINE:=BSMIN;
	     UPTRENDLINE,COLORRED;
	     END 
	END 
	ELSE BEGIN
		UPTRENDBUFFER:=BSMIN;
	    IF (LINE>0) THEN  BEGIN
	    UPTRENDLINE:=BSMIN;
	    UPTRENDLINE,COLORRED;
	    END 
	    UPTRENDSIGNAL:=-1;
	END
	IF (SIGNAL=2) THEN  UPTRENDBUFFER:=0;   
	  DOWNTRENDBUFFER:=-1.0;
	  DOWNTRENDLINE:=9999;
END
IF (TREND0<0) THEN BEGIN
	IF (SIGNAL>0 && LDTB=-1.0) THEN BEGIN
		DOWNTRENDSIGNAL:=BSMAX;
	    IF (LINE>0) THEN  BEGIN
	    	DOWNTRENDLINE:=BSMAX;
	    	DOWNTRENDLINE,COLORCYAN;
	    END 
	END 
	ELSE BEGIN
		DOWNTRENDBUFFER:=BSMAX;
	    IF (LINE>0)THEN DOWNTRENDLINE:=BSMAX;
	    DOWNTRENDSIGNAL:=-1;
	END 
	  IF (SIGNAL=2)THEN DOWNTRENDBUFFER:=0;    
	  UPTRENDBUFFER:=-1.0;
	  UPTRENDLINE:=999;
END


登录后方可回帖

登 录
信息栏

本社区严禁出现如下现象:

1、发布广告宣传、QQ微信群的帖子。

2、发布个人人身攻击的言辞,发回帖中出现严重的政治言论。

3、纯表情以及其他毫无意义的发贴回帖,标题党或发布严重误导的贴子。

祝大家早日达成目标。

Loading...